How to set up the Oculus Link

Oculus Link is the optic cable that connects Oculus Quest to your gaming PC. If you intend to use the Oculus Link to get your Oculus Quest to function similar to the Oculus Rift, you should ensure that your PC falls under recommended VR requirements.

Here’s a step-by-step method of how you can set up your Quest with Oculus Link:

  1. Download the Oculus PC software
  2. Ensure that you have a compatible cable for Oculus Link
  3. Update your Oculus software on both your PC and your Quest.
  4. Once you have everything up-to-date, open the Oculus app on your PC.
  5. Switch on your Quest device.
  6. Plug in your USB cable into a USB port on your PC.
  7. Plug the other end of the cable into your headset.
  8. You will see a message displayed in VR, prompting you to Allow access to data.
  9. Select Deny. If you accidentally selected Allow, unplug your USB cable from your Quest and plug it in again.
  10. When you are prompted to Enable Oculus Link (beta), select Enable.

That’s it! Oculus Link is now active. You’ll see your Oculus Quest load Oculus Home

1 Like

Also note, that if you have a so called “VR-ready” gaming laptop, you will probably also make sure the Oculus software is using the dedicated GPU.

The symtom of this is when you start Oculus Link in your Quest, you see three dots, and then gets kicked out.

The sollution is to either deactivate the dicrete graphics (the build in GPU) entirely in the Device Manager, or to set that all Oculus processes/executables should use the dedicated GPU.


Hey folks, I’m trying to get Oculus Link running on a VR ready gaming laptop, and have experienced the exact issue described above!

I can’t seem to find an obvious setting in the Oculus software for deactivating discrete graphics, or to force that all Oculus processes/executables should use the dedicated GPU. Whereabouts would I find the setting you are referring to?

Thanks in advance :slight_smile:

Hope you solved it already. Didn’t find the guide I was using. But there is a place in windows where you can decide what programs should use the dedicated GPU or not. And there you need to add all Oculus executables that is used. There is around 4 programs I think. Hopefully you can find it by googling a bit.

Else some users have had success with simply disable the integrated GPU in device manager. Or connect an external monitor that somehow will force the graphics card to switch.

Here is the bug you can vote on to get some attention to the problem: